Vulnerability · Published Jan 30, 2020 · Assigned by GitHub_M
CVE-2020-5230Opencast uses unsafe identifiers
High 7.7
In plain English
A high-severity security flaw in opencast from opencast. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Opencast before 8.1 and 7.6 allows almost arbitrary identifiers for media packages and elements to be used. This can be problematic for operation and security since such identifiers are sometimes used for file system operations which may lead to an attacker being able to escape working directories and write files to other locations. In addition, Opencast's Id.toString(…) vs Id.compact(…) behavior, the latter trying to mitigate some of the file system problems, can cause errors due to identifier mismatch since an identifier may unintentionally change. This issue is fixed in Opencast 7.6 and 8.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opencastproject:base | 7.6 | GHSA-w29m-fjp4-qhmq |
| Maven | org.opencastproject:base | 8.1 | GHSA-w29m-fjp4-qhmq |
Affected products (as reported)
Weakness: CWE-99 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N