Vulnerability · Published Jan 28, 2020 · Assigned by GitHub_M
CVE-2020-5215Segmentation faultin TensorFlow when converting a Python string to tf.float16
Medium 5.0
In plain English
A medium-severity security flaw in TensorFlow from TensorFlow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In TensorFlow before 1.15.2 and 2.0.1, converting a string (from Python) to a tf.float16 value results in a segmentation fault in eager mode as the format checks for this use case are only in the graph mode. This issue can lead to denial of service in inference/training where a malicious attacker can send a data point which contains a string instead of a tf.float16 value. Similar effects can be obtained by manipulating saved models and checkpoints whereby replacing a scalar tf.float16 value with a scalar string will trigger this issue due to automatic conversions. This can be easily reproduced by tf.constant("hello", tf.float16), if eager execution is enabled. This issue is patched in TensorFlow 1.15.1 and 2.0.1 with this vulnerability patched. TensorFlow 2.1.0 was released after we fixed the issue, thus it is not affected. Users are encouraged to switch to TensorFlow 1.15.1, 2.0.1 or 2.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | tensorflow | 1.15.2, 2.0.1 | PYSEC-2020-258 |
| PyPI | tensorflow | 1.15.2 | GHSA-977j-xj7q-2jr9 |
| PyPI | tensorflow | 2.0.1 | GHSA-977j-xj7q-2jr9 |
| PyPI | tensorflow-cpu | 1.15.2, 2.0.1 | PYSEC-2020-303 |
| PyPI | tensorflow-cpu | 2.0.1 | GHSA-977j-xj7q-2jr9 |
| PyPI | tensorflow-cpu | 1.15.2 | GHSA-977j-xj7q-2jr9 |
| PyPI | tensorflow-gpu | 1.15.2, 2.0.1 | PYSEC-2020-338 |
| PyPI | tensorflow-gpu | 1.15.2 | GHSA-977j-xj7q-2jr9 |
| PyPI | tensorflow-gpu | 2.0.1 | GHSA-977j-xj7q-2jr9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| TensorFlow | TensorFlow | < 1.15.2= 2.0.0 |
Weakness: CWE-754 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-977j-xj7q-2jr9 x_refsource_CONFIRM
- https://github.com/tensorflow/tensorflow/commit/5ac1b9e24ff6afc465756edf845d2e9660bd34bf x_refsource_MISC
- https://github.com/tensorflow/tensorflow/releases/tag/v1.15.2 x_refsource_MISC
- https://github.com/tensorflow/tensorflow/releases/tag/v2.0.1 x_refsource_MISC