Vulnerability · Published Jun 12, 2020 · Assigned by GitHub_M

CVE-2020-4046Authenticated XSS through embed block in WordPress

Medium 5.4

In plain English

A medium-severity security flaw in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)2.1%top 18.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.4.2+dfsg1-1DEBIAN-CVE-2020-4046
Debian:13wordpress5.4.2+dfsg1-1DEBIAN-CVE-2020-4046
Debian:14wordpress5.4.2+dfsg1-1DEBIAN-CVE-2020-4046
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2020-4046

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop >= 5.4.0, < 5.4.2>= 5.3.0, < 5.3.4>= 5.2.0, < 5.2.7>= 5.1.0, < 5.1.6>= 5.0.0, < 5.0.10>= 4.9.0, < 4.9.15>= 4.8.0, < 4.8.14>= 4.7.0, < 4.7.18

Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References