Vulnerability · Published Jun 10, 2020 · Assigned by GitHub_M

CVE-2020-4043Phar unserialization vulnerability in phpMussel

High 7.7

In plain English

A high-severity unsafe deserialization in phpMussel from phpMussel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)2.6%top 14.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmaikuolan/phpmussel1.6.0GHSA-qr95-4mq5-r3fh
Packagistphpmussel/phpmussel1.6.0GHSA-qr95-4mq5-r3fh

Affected products (as reported)

VendorProductVersions
phpMussel phpMussel >= 1.0.0, < 1.6.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

References