Vulnerability · Published Dec 27, 2022 · Assigned by VulDB

CVE-2020-36636OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting

Low 3.5

In plain English

A low-severity cross-site scripting in Admin UI Module from OpenMRS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities).

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)1.0%top 36.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 702fbfdac7c4418f23bb5f6452482b4a88020061. It is recommended to upgrade the affected component. VDB-216918 is the identifier assigned to this vulnerability.

Affected products (as reported)

VendorProductVersions
OpenMRS Admin UI Module 1.01.11.21.31.4

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

References