Vulnerability · Published Dec 27, 2022 · Assigned by VulDB
CVE-2020-36635OpenMRS Appointment Scheduling Module AppointmentTypeValidator.java validateFieldName cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in Appointment Scheduling Module from OpenMRS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities).
Official description
A vulnerability was found in OpenMRS Appointment Scheduling Module up to 1.12.x. It has been classified as problematic. This affects the function validateFieldName of the file api/src/main/java/org/openmrs/module/appointmentscheduling/validator/AppointmentTypeValidator.java. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.13.0 is able to address this issue. The name of the patch is 34213c3f6ea22df427573076fb62744694f601d8. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216915.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMRS | Appointment Scheduling Module | 1.01.11.21.31.41.51.61.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.216915 vdb-entry, technical-description
- https://vuldb.com/?ctiid.216915 signature, permissions-required
- https://github.com/openmrs/openmrs-module-appointmentscheduling/pull/32 issue-tracking
- https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/34213c3f6ea22df427573076fb62744694f601d8 patch
- https://github.com/openmrs/openmrs-module-appointmentscheduling/releases/tag/1.13.0 patch