Vulnerability · Published Dec 21, 2020 · Assigned by GitHub_M

CVE-2020-26263RSA vulnerability in tslite-ng

High 7.5

In plain English

A high-severity security flaw in tlslite-ng from tlsfuzzer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.5%top 25.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

tlslite-ng is an open source python library that implements SSL and TLS cryptographic protocols. In tlslite-ng before versions 0.7.6 and 0.8.0-alpha39, the code that performs decryption and padding check in RSA PKCS#1 v1.5 decryption is data dependant. In particular, the code has multiple ways in which it leaks information about the decrypted ciphertext. It aborts as soon as the plaintext doesn't start with 0x00, 0x02. All TLS servers that enable RSA key exchange as well as applications that use the RSA decryption API directly are vulnerable. This is patched in versions 0.7.6 and 0.8.0-alpha39. Note: the patches depend on Python processing the individual bytes in side-channel free manner, this is known to not the case (see reference). As such, users that require side-channel resistance are recommended to use different TLS implementations, as stated in the security policy of tlslite-ng.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPItlslite-ng0.7.6GHSA-wvcv-832q-fjg7
PyPItlslite-ng0.7.6PYSEC-2020-143

Affected products (as reported)

VendorProductVersions
tlsfuzzer tlslite-ng < 0.7.6>= 0.8.0-alpha1, < 0.8.0-alpha39

Weakness: CWE-326 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References