Vulnerability · Published Nov 19, 2020 · Assigned by redhat
CVE-2020-25698
High 7.5
In plain English
A high-severity improper access control in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.9%top 20.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | moodle/moodle | 3.9.3 | GHSA-vxhx-gmhm-623c |
| Packagist | moodle/moodle | 3.8.6 | GHSA-vxhx-gmhm-623c |
| Packagist | moodle/moodle | 3.7.9 | GHSA-vxhx-gmhm-623c |
| Packagist | moodle/moodle | 3.5.15 | GHSA-vxhx-gmhm-623c |
Affected products (as reported)
Weakness: CWE-284
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1895419 x_refsource_MISC
- https://moodle.org/mod/forum/discuss.php?d=413935 x_refsource_MISC
- FEDORA-2020-304aa2c365 vendor-advisory, x_refsource_FEDORA
- FEDORA-2020-db73e37548 vendor-advisory, x_refsource_FEDORA