Vulnerability · Published Dec 8, 2020 · Assigned by redhat
CVE-2020-25630
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.4%top 28.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | moodle/moodle | 3.9.2 | GHSA-66xp-28cq-mrf2 |
| Packagist | moodle/moodle | 3.8.5 | GHSA-66xp-28cq-mrf2 |
| Packagist | moodle/moodle | 3.7.8 | GHSA-66xp-28cq-mrf2 |
| Packagist | moodle/moodle | 3.5.14 | GHSA-66xp-28cq-mrf2 |
Affected products (as reported)
Weakness: CWE-400
References
- https://moodle.org/mod/forum/discuss.php?d=410842 x_refsource_CONFIRM