Vulnerability · Published Dec 8, 2020 · Assigned by redhat

CVE-2020-25628

Medium 6.1

In plain English

A medium-severity cross-site scripting in Moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.1Medium
Exploit odds (30 days)1.0%top 37.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.9.2GHSA-5x33-h32w-6vr2
Packagistmoodle/moodle3.8.5GHSA-5x33-h32w-6vr2
Packagistmoodle/moodle3.7.8GHSA-5x33-h32w-6vr2
Packagistmoodle/moodle3.5.14GHSA-5x33-h32w-6vr2

Affected products (as reported)

VendorProductVersions
n/a Moodle 3.9 to 3.9.13.8 to 3.8.43.7 to 3.7.73.5 to 3.5.13earlier unsupported versions

Weakness: CWE-79

References