Vulnerability · Published Dec 8, 2020 · Assigned by openssl
CVE-2020-1971EDIPARTYNAME NULL pointer dereference
Medium 5.9
In plain English
A medium-severity null pointer dereference in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 7.0% (higher than 94% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
The X.509 GeneralName type is a generic type for representing different types of names. One of those name types is known as EDIPartyName. OpenSSL provides a function GENERAL_NAME_cmp which compares different instances of a GENERAL_NAME to see if they are equal or not. This function behaves incorrectly when both GENERAL_NAMEs contain an EDIPARTYNAME. A NULL pointer dereference and a crash may occur leading to a possible denial of service attack. OpenSSL itself uses the GENERAL_NAME_cmp function for two purposes: 1) Comparing CRL distribution point names between an available CRL and a CRL distribution point embedded in an X509 certificate 2) When verifying that a timestamp response token signer matches the timestamp authority name (exposed via the API functions TS_RESP_verify_response and TS_RESP_verify_token) If an attacker can control both items being compared then that attacker could trigger a crash. For example if the attacker can trick a client or server into checking a malicious certificate against a malicious CRL then this may occur. Note that some applications automatically download CRLs based on a URL embedded in a certificate. This checking happens prior to the signatures on the certificate and CRL being verified. OpenSSL's s_server, s_client and verify tools have support for the "-crl_download" option which implements automatic CRL downloading and this attack has been demonstrated to work against those tools. Note that an unrelated bug means that affected versions of OpenSSL cannot parse or construct correct encodings of EDIPARTYNAME. However it is possible to construct a malformed EDIPARTYNAME that OpenSSL's parser will accept and hence trigger this attack. All OpenSSL 1.1.1 and 1.0.2 versions are affected by this issue. Other OpenSSL releases are out of support and have not been checked. Fixed in OpenSSL 1.1.1i (Affected 1.1.1-1.1.1h). Fixed in OpenSSL 1.0.2x (Affected 1.0.2-1.0.2w).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | libressl | 3.1.5-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.21 | libressl | 3.1.5-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.22 | libressl | 3.1.5-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.23 | libressl | 3.1.5-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.24 | libressl | 3.1.5-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.20 | openssl | 1.1.1i-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.21 | openssl | 1.1.1i-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.22 | openssl | 1.1.1i-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.23 | openssl | 1.1.1i-r0 | ALPINE-CVE-2020-1971 |
| Alpine:v3.24 | openssl | 1.1.1i-r0 | ALPINE-CVE-2020-1971 |
| Debian:12 | openssl | 1.1.1i-1 | DEBIAN-CVE-2020-1971 |
| Debian:13 | openssl | 1.1.1i-1 | DEBIAN-CVE-2020-1971 |
| Debian:14 | openssl | 1.1.1i-1 | DEBIAN-CVE-2020-1971 |
Affected products (as reported)
Weakness: CWE-476 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://www.openssl.org/news/secadv/20201208.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=f960d81215ebf3f65e03d4d5d857fb9b666d6920
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=2154ab83e14ede338d2ede9bbe5cdfce5d5a6c9e
- DSA-4807 vendor-advisory
- FreeBSD-SA-20:33 vendor-advisory
- [debian-lts-announce] 20201214 [SECURITY] [DLA 2493-1] openssl1.0 security update mailing-list
- [debian-lts-announce] 20201214 [SECURITY] [DLA 2492-1] openssl security update mailing-list
- FEDORA-2020-ef1870065a vendor-advisory
- [pulsar-commits] 20201216 [GitHub] [pulsar] phijohns-tibco opened a new issue #8978: OpenSSL needs to be updated to 1.1.1i current version is unsupported. mailing-list
- FEDORA-2020-a31b01e945 vendor-advisory
- GLSA-202012-13 vendor-advisory
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.tenable.com/security/tns-2020-11
- https://security.netapp.com/advisory/ntap-20201218-0005/
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44676
- [tomcat-dev] 20210207 [Bug 65126] New: A security vulnerability cve-2020-1971 in Tomcat dependency Library in version 9.0.40. mailing-list
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-10
- https://www.tenable.com/security/tns-2021-09
- https://security.netapp.com/advisory/ntap-20210513-0002/
- https://www.oracle.com//security-alerts/cpujul2021.html
- [oss-security] 20210914 Re: Oracle Solaris membership in the distros list mailing-list
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.netapp.com/advisory/ntap-20240621-0006/