Vulnerability · Published May 14, 2020 · Assigned by apache

CVE-2020-11971

High 7.5

In plain English

A high-severity security flaw in Apache Camel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.0% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)14.0%top 3.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Camel's JMX is vulnerable to Rebind Flaw. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.x, 3.0.0 up to 3.1.0 is affected. Users should upgrade to 3.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel3.2.0GHSA-hfg5-xpvw-c9x4
Mavenorg.apache.camel:camel-core3.2.0GHSA-hfg5-xpvw-c9x4
Mavenorg.apache.camel:camel-management3.2.0GHSA-hfg5-xpvw-c9x4

Affected products (as reported)

VendorProductVersions
n/a Apache Camel Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0

References