Vulnerability · Published May 28, 2020 · Assigned by GitHub_M

CVE-2020-11082Cross-Site Scripting in Kaminari

Medium 6.4

In plain English

A medium-severity cross-site scripting in Kaminari from kaminari. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)1.5%top 24.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-kaminari1.0.1-6DEBIAN-CVE-2020-11082
Debian:13ruby-kaminari1.0.1-6DEBIAN-CVE-2020-11082
Debian:14ruby-kaminari1.0.1-6DEBIAN-CVE-2020-11082
RubyGemskaminari1.2.1GHSA-r5jw-62xg-j433

Affected products (as reported)

VendorProductVersions
kaminari Kaminari < 1.2.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L

References