Vulnerability · Published May 7, 2020 · Assigned by GitHub_M
CVE-2020-11052Improper Restriction of Excessive Authentication Attempts in Sorcery
High 8.3
In plain English
A high-severity security flaw in Sorcery from Sorcery. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | sorcery | 0.15.0 | GHSA-jc8m-cxhj-668x |
Affected products (as reported)
Weakness: CWE-307 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
References
- https://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x x_refsource_CONFIRM
- https://github.com/Sorcery/sorcery/issues/231 x_refsource_MISC
- https://github.com/Sorcery/sorcery/pull/235 x_refsource_MISC
- https://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7 x_refsource_MISC