Vulnerability · Published Sep 14, 2020 · Assigned by intel

CVE-2020-0570

High 7.3

In plain English

A high-severity security flaw in QT Library. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.3High
Exploit odds (30 days)0.6%top 52.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncontrolled search path in the QT Library before 5.14.0, 5.12.7 and 5.9.10 may allow an authenticated user to potentially enable elevation of privilege via local access.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8qt5-qtbase-static5.12.5-6.el8ALSA-2020:4690
AlmaLinux:8qt5-qttools-static5.12.5-2.el8ALSA-2020:4690
Debian:12qtbase-opensource-src5.12.5+dfsg-8DEBIAN-CVE-2020-0570
Debian:13qtbase-opensource-src5.12.5+dfsg-8DEBIAN-CVE-2020-0570
Debian:14qtbase-opensource-src5.12.5+dfsg-8DEBIAN-CVE-2020-0570
Rocky Linux:8qt5-qtwebsockets0:5.12.5-2.el8RLSA-2020:4690

Affected products (as reported)

VendorProductVersions
n/a QT Library Fixed in qt 5.14.0, qt 5.12.7, qt 5.9.10

References