Vulnerability · Published Sep 1, 2026 · Assigned by GitHub_M

CVE-2026-83607xmldom: Element name injection via createElement() bypasses requireWellFormed

High 8.7

In plain English

A high-severity security flaw in xmldom from xmldom. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.6%top 50.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Document.createElement(tagName) stores an unvalidated element name and XMLSerializer.serializeToString() emits that name verbatim. The requireWellFormed: true path did not validate the element qualified name or synthesized xmlns:PREFIX declaration, so attacker-controlled tag names could inject attributes, elements, or processing instructions into serialized XML or HTML and could cause cross-site scripting when browser-consumed. The unchecked values violate the XML QName constraint, and default serialization and creation-time createElement() behavior remain permissive. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-xmldomno fix listedDEBIAN-CVE-2026-83607
Debian:13node-xmldomno fix listedDEBIAN-CVE-2026-83607
Debian:14node-xmldom0.9.11-1DEBIAN-CVE-2026-83607
Ubuntu:22.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-83607
Ubuntu:24.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-83607
Ubuntu:26.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-83607
npm@xmldom/xmldom0.8.14GHSA-w2rr-34g9-rvrj
npm@xmldom/xmldom0.9.11GHSA-w2rr-34g9-rvrj
npmxmldomno fix listedGHSA-w2rr-34g9-rvrj

Affected products (as reported)

VendorProductVersions
xmldom xmldom <= 0.6.0
@xmldom xmldom >= 0.7.0, < 0.8.14>= 0.9.0, < 0.9.11

Weakness: CWE-91 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References