Vulnerability · Published Aug 13, 2026 · Assigned by GitHub_M
CVE-2026-73489Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records
Medium 4.3
In plain English
A medium-severity security flaw in russh from Eugeny. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Russh is a Rust SSH client & server library. Prior to 0.62.4, an authenticated SSH client can cause a denial of service by sending a pty-req channel request with more than 130 terminal-mode records. The parser in russh/src/server/encrypted.rs stores terminal modes in a fixed 130-entry [(Pty::TTY_OP_END, 0); 130] array but continues increasing the mode count, then constructs an out-of-bounds slice and panics before the application pty_request handler runs. The panic terminates the server session task without causing memory corruption. This issue is fixed in version 0.62.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | rust-russh | 0.64.1-1 | DEBIAN-CVE-2026-73489 |
Affected products (as reported)
Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/Eugeny/russh/security/advisories/GHSA-cqjc-rmpq-xprq x_refsource_CONFIRM
- https://github.com/Eugeny/russh/commit/8912512371820167a12a0a638bd666856ce458ad x_refsource_MISC
- https://github.com/Eugeny/russh/releases/tag/v0.62.4 x_refsource_MISC