Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M
CVE-2026-68939Pyenv: Glob/wildcard metacharacters bypass is_version_safe(), causing silent version/interpreter substitution via unquoted expansion (CVE-2022-35861 residual)
Low 2.0
In plain English
A low-severity OS command injection in pyenv from pyenv. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).
Official description
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | pyenv | no fix listed | DEBIAN-CVE-2026-68939 |
| Debian:14 | pyenv | no fix listed | DEBIAN-CVE-2026-68939 |
| Ubuntu:26.04:LTS | pyenv | no fix listed | UBUNTU-CVE-2026-68939 |
| Ubuntu:26.10 | pyenv | no fix listed | UBUNTU-CVE-2026-68939 |
Affected products (as reported)
Weakness: CWE-78, CWE-88, CWE-155 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/pyenv/pyenv/security/advisories/GHSA-g478-f579-9vp9 x_refsource_CONFIRM
- https://github.com/pyenv/pyenv/commit/95df7dbc7b34595b47c9b922de198547effda819 x_refsource_MISC
- https://github.com/pyenv/pyenv/releases/tag/v2.8.0 x_refsource_MISC