Vulnerability · Published Jul 22, 2026 · Assigned by VulnCheck

CVE-2026-65591n8n before 1.123.64 Sanitizer Bypass Remote Code Execution

High 8.9

In plain English

A high-severity expression language injection in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.9High
Exploit odds (30 days)0.7%top 46.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmn8n1.123.64GHSA-pm35-fqvh-cq5g
npmn8n2.30.1GHSA-pm35-fqvh-cq5g
npmn8n2.29.8GHSA-pm35-fqvh-cq5g

Affected products (as reported)

VendorProductVersions
n8n-io n8n 0 – before 1.123.64
n8n-io n8n 2.30.0 – before 2.30.1
n8n-io n8n 2.0.0-rc.0 – before 2.29.8

Weakness: CWE-917 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L

References