Vulnerability · Published Jul 27, 2026 · Assigned by GitHub_M

CVE-2026-64642Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale

High 8.3

In plain English

A high-severity security flaw in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.6%top 49.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnext16.2.11GHSA-6gpp-xcg3-4w24

Affected products (as reported)

VendorProductVersions
vercel next.js >= 16.0.0, < 16.2.11

Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References