Vulnerability · Published Oct 30, 2026 · Assigned by GitHub_M

CVE-2026-61846Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage

Medium 6.3

In plain English

A medium-severity security flaw in crass from rgrove. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.5%top 58.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses `CSS simple blocks and functions` without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises `SystemStackError`: stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-crassno fix listedDEBIAN-CVE-2026-61846
Debian:13ruby-crassno fix listedDEBIAN-CVE-2026-61846
Debian:14ruby-crass1.0.7-1DEBIAN-CVE-2026-61846
RubyGemscrass1.0.7GHSA-6jxj-px6v-747w
Ubuntu:22.04:LTSruby-crassno fix listedUBUNTU-CVE-2026-61846
Ubuntu:24.04:LTSruby-crassno fix listedUBUNTU-CVE-2026-61846
Ubuntu:26.04:LTSruby-crassno fix listedUBUNTU-CVE-2026-61846
Ubuntu:26.10ruby-crassno fix listedUBUNTU-CVE-2026-61846

Affected products (as reported)

VendorProductVersions
rgrove crass < 1.0.7

Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L

References