Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M

CVE-2026-61544libp2p-quic: Remote panic via certificate expiry race during QUIC handshake

High 8.2

In plain English

A high-severity security flaw in rust-libp2p from libp2p. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 79.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:26.04:LTSrust-libp2p-identityno fix listedUBUNTU-CVE-2026-61544
Ubuntu:26.10rust-libp2p-identityno fix listedUBUNTU-CVE-2026-61544

Affected products (as reported)

VendorProductVersions
libp2p rust-libp2p < 0.13.1

Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References