Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M
CVE-2026-59882guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
Medium 4.2
In plain English
A medium-severity security flaw in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-guzzlehttp-psr7 | no fix listed | DEBIAN-CVE-2026-59882 |
| Debian:13 | php-guzzlehttp-psr7 | no fix listed | DEBIAN-CVE-2026-59882 |
| Debian:14 | php-guzzlehttp-psr7 | 2.12.3-1 | DEBIAN-CVE-2026-59882 |
| Packagist | guzzlehttp/psr7 | 2.12.3 | GHSA-c2w2-prh8-qm98 |
| Ubuntu:24.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-59882 |
| Ubuntu:25.10 | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-59882 |
| Ubuntu:26.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-59882 |
Affected products (as reported)
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/guzzle/psr7/security/advisories/GHSA-c2w2-prh8-qm98 x_refsource_CONFIRM
- https://github.com/guzzle/psr7/pull/811 x_refsource_MISC
- https://github.com/guzzle/psr7/commit/ddd64f17d4cc1f7e5ffe6fd2c989ec7221712580 x_refsource_MISC
- https://github.com/guzzle/psr7/releases/tag/2.12.3 x_refsource_MISC