Vulnerability · Published Aug 21, 2026 · Assigned by GitHub_M

CVE-2026-54789mod_auth_openidc has out-of-bounds read and write in state cookie parsing

High 7.5

In plain English

A high-severity out-of-bounds read in mod_auth_openidc from OpenIDC. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 57.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8cjose0.6.1-5.module_el8.10.0+4297+63ae3533ALSA-2026:77369
AlmaLinux:8cjose-devel0.6.1-5.module_el8.10.0+4297+63ae3533ALSA-2026:77369
AlmaLinux:10mod_auth_openidc2.4.16.11-1.el10_2.1ALSA-2026:75581
AlmaLinux:8mod_auth_openidc2.4.9.4-9.module_el8.10.0+4297+63ae3533ALSA-2026:77369
AlmaLinux:9mod_auth_openidc2.4.16.11-1.el9_8.1ALSA-2026:79177
Debian:12libapache2-mod-auth-openidc2.4.12.3-2+deb12u5DEBIAN-CVE-2026-54789
Debian:13libapache2-mod-auth-openidc2.4.17-1+deb13u1DEBIAN-CVE-2026-54789
Debian:14libapache2-mod-auth-openidc2.4.19.4-1DEBIAN-CVE-2026-54789
Rocky Linux:8cjose0:0.6.1-5.module+el8.10.0+40373+8a3f15d2RLSA-2026:77369
Rocky Linux:10mod_auth_openidc0:2.4.16.11-1.el10_2.1RLSA-2026:75581
Rocky Linux:8mod_auth_openidc0:2.4.9.4-9.module+el8.10.0+40373+8a3f15d2RLSA-2026:77369
Rocky Linux:9mod_auth_openidc0:2.4.16.11-1.el9_8.1RLSA-2026:79177
Ubuntu:22.04:LTSlibapache2-mod-auth-openidcno fix listedUBUNTU-CVE-2026-54789
Ubuntu:24.04:LTSlibapache2-mod-auth-openidcno fix listedUBUNTU-CVE-2026-54789
Ubuntu:26.04:LTSlibapache2-mod-auth-openidcno fix listedUBUNTU-CVE-2026-54789

Affected products (as reported)

VendorProductVersions
OpenIDC mod_auth_openidc < 2.4.19.4

Weakness: CWE-125, CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References