Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-54307n8n: Credential Exfiltration via Permission Bypass

High 8.5

In plain English

A high-severity incorrect authorization in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.4%top 67.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, a member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmn8n1.123.55GHSA-pmqw-72cg-wx85
npmn8n2.26.2GHSA-pmqw-72cg-wx85
npmn8n2.25.7GHSA-pmqw-72cg-wx85

Affected products (as reported)

VendorProductVersions
n8n-io n8n < 1.123.55>= 2.0.0-rc.0, < 2.25.7>= 2.26.0, < 2.26.2

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:L

References