Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M

CVE-2026-52858Vim: Arbitrary Code Execution via Python Omni-Completion

High 7.3

In plain English

A high-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.3High
Exploit odds (30 days)0.2%top 89.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to version 9.2.0561, the Python omni-completion script in python3complete.vim for Vim with the +python3 interpreter enabled (and the legacy pythoncomplete.vim for builds with the +python interpreter) executes the import and from statements found in the current buffer through Python's import machinery. Because the buffer's working directory is on sys.path, opening a hostile .py file with a sibling Python package and invoking omni-completion runs that package's top-level code as the editing user. This issue has been patched in version 9.2.0561.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10vim-X112:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-X112:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-X112:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-common2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-common2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-common2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-data2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:10vim-enhanced2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-enhanced2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-enhanced2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-filesystem2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-filesystem2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-filesystem2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10vim-minimal2:9.1.083-9.el10_2.7ALSA-2026:38509
AlmaLinux:8vim-minimal2:8.0.1763-27.el8_10ALSA-2026:38510
AlmaLinux:9vim-minimal2:8.2.2637-26.el9_8.10ALSA-2026:38511
AlmaLinux:10xxd2:9.1.083-9.el10_2.7ALSA-2026:38509
Alpine:v3.23vim9.2.0498-r0ALPINE-CVE-2026-52858
Alpine:v3.24vim9.2.0498-r0ALPINE-CVE-2026-52858
Debian:12vimno fix listedDEBIAN-CVE-2026-52858
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-52858
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-52858
Rocky Linux:10vim2:9.1.083-9.el10_2.7RLSA-2026:38509
Rocky Linux:8vim2:8.0.1763-27.el8_10RLSA-2026:38510
Rocky Linux:9vim2:8.2.2637-26.el9_8.10RLSA-2026:38511
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.32UBUNTU-CVE-2026-52858
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.16UBUNTU-CVE-2026-52858
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.7UBUNTU-CVE-2026-52858
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.5UBUNTU-CVE-2026-52858

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0561

Weakness: CWE-94, CWE-95, CWE-829 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References