Vulnerability · Published Jul 9, 2026 · Assigned by GitHub_M
CVE-2026-49276Kirby: Self cross-site scripting (self-XSS) in the writer field
High 7.4
In plain English
A high-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites using the writer field in any blueprint allowed a scripting link to be included as the target of a link or email link in writer mark components, making the target clickable by the user who entered it and enabling self cross-site scripting in the Panel. This issue is fixed in versions 4.9.4 and 5.4.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | getkirby/cms | 4.9.4 | GHSA-rhj6-r49h-5932 |
| Packagist | getkirby/cms | 5.4.4 | GHSA-rhj6-r49h-5932 |
Affected products (as reported)
Weakness: CWE-83 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-rhj6-r49h-5932 x_refsource_CONFIRM
- https://github.com/getkirby/kirby/releases/tag/4.9.4 x_refsource_MISC
- https://github.com/getkirby/kirby/releases/tag/5.4.4 x_refsource_MISC