Vulnerability · Published Jun 17, 2026 · Assigned by GitHub_M
CVE-2026-48817Starlette: Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr`
Medium 5.3
In plain English
A medium-severity security flaw in starlette from Kludex. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Starlette is a lightweight ASGI framework/toolkit. In versions 1.0.1 and below, when dispatching a request, HTTPEndpoint selects the handler by lowercasing the HTTP method and looking it up as an attribute with getattr, without restricting the lookup to a known set of HTTP verbs. When an HTTPEndpoint subclass is registered through Route(...) without an explicit methods= argument, the route does not constrain the method and every method reaches the endpoint. If a non-standard HTTP method whose lowercased name matches an attribute on the endpoint subclass reaches the endpoint, that attribute is invoked as if it were a request handler. An attacker can use this to reach methods that were never meant to be HTTP handlers, such as internal helpers, without the authorization checks applied by the intended public handler. An application (including Starlette-based frameworks like FastAPI) is affected if it registers an HTTPEndpoint subclass via Route(...) without explicitly setting methods=, and that subclass includes extra methods named like non-standard HTTP verbs that take one request argument and return a response. This issue has been fixed in version 1.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | starlette | 0.26.1-1+deb12u2 | DEBIAN-CVE-2026-48817 |
| Debian:13 | starlette | 0.46.1-3+deb13u3 | DEBIAN-CVE-2026-48817 |
| Debian:14 | starlette | 1.1.0-1 | DEBIAN-CVE-2026-48817 |
| PyPI | starlette | 1.1.0 | GHSA-x746-7m8f-x49c |
| PyPI | starlette | 1.1.0 | PYSEC-2026-2280 |
| Ubuntu:22.04:LTS | starlette | no fix listed | UBUNTU-CVE-2026-48817 |
| Ubuntu:24.04:LTS | starlette | no fix listed | UBUNTU-CVE-2026-48817 |
| Ubuntu:25.10 | starlette | no fix listed | UBUNTU-CVE-2026-48817 |
| Ubuntu:26.04:LTS | starlette | no fix listed | UBUNTU-CVE-2026-48817 |
| Ubuntu:26.10 | starlette | no fix listed | UBUNTU-CVE-2026-48817 |
Affected products (as reported)
Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
References
- https://github.com/Kludex/starlette/security/advisories/GHSA-x746-7m8f-x49c x_refsource_CONFIRM
- https://github.com/Kludex/starlette/releases/tag/1.1.0 x_refsource_MISC