Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-48807Twig: Sandbox `__toString()` policy bypass via `Traversable` in `join` and `replace` filters
High 7.1
In plain English
A high-severity incorrect authorization in Twig from twigphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Twig is a template language for PHP. Prior to 3.27.0, the sandbox __toString() checks do not fully cover Traversable values passed to join and replace filters or operands evaluated by the in and not in operators, allowing contained Stringable objects to be coerced to strings without consulting the sandbox policy. This issue is fixed in version 3.27.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | php-twig | 3.27.0-1 | DEBIAN-CVE-2026-48807 |
| Packagist | twig/twig | 3.27.0 | GHSA-8x9c-rmqh-456c |
| Ubuntu:25.10 | php-twig | no fix listed | UBUNTU-CVE-2026-48807 |
| Ubuntu:26.10 | php-twig | no fix listed | UBUNTU-CVE-2026-48807 |
Affected products (as reported)
Weakness: CWE-693, CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/twigphp/Twig/security/advisories/GHSA-8x9c-rmqh-456c x_refsource_CONFIRM
- https://github.com/twigphp/Twig/releases/tag/v3.27.0 x_refsource_MISC