Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-46644symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload decodes to ASCII-only: insecure equivalence

Medium 6.9

In plain English

A medium-severity security flaw in polyfill from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.5%top 54.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony Polyfill backports PHP features and provides compatibility layers for extensions and functions. From 1.17.1 until 1.38.1, symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload is empty or decodes to ASCII-only code points because Idn::process() does not enforce the UTS #46 revision 33 requirement that decoded ACE labels contain at least one non-ASCII code point. Originally unequal domain names can be regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing, and server-side request forgery in applications using the polyfill to canonicalise or compare hostnames. This issue is fixed in version 1.38.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-symfony-polyfillno fix listedDEBIAN-CVE-2026-46644
Debian:14php-symfony-polyfill1.38.1-1DEBIAN-CVE-2026-46644
Packagistsymfony/polyfill1.38.1GHSA-2xf4-cg6j-vhgq
Packagistsymfony/polyfill-intl-idn1.38.1GHSA-2xf4-cg6j-vhgq
Ubuntu:22.04:LTSphp-symfony-polyfillno fix listedUBUNTU-CVE-2026-46644
Ubuntu:24.04:LTSphp-symfony-polyfillno fix listedUBUNTU-CVE-2026-46644
Ubuntu:25.10php-symfony-polyfillno fix listedUBUNTU-CVE-2026-46644
Ubuntu:26.04:LTSphp-symfony-polyfillno fix listedUBUNTU-CVE-2026-46644
Ubuntu:26.10php-symfony-polyfillno fix listedUBUNTU-CVE-2026-46644

Affected products (as reported)

VendorProductVersions
symfony polyfill >= 1.17.1, < 1.38.1
symfony polyfill-intl-idn >= 1.17.1, < 1.38.1

Weakness: CWE-1289 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N

References