Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-45133Symfony: [Yaml] Harden the parser when handling untrusted input
High 8.2
In plain English
A high-severity regular-expression denial of service in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | symfony | 5.4.53+dfsg-0+deb12u1 | DEBIAN-CVE-2026-45133 |
| Debian:13 | symfony | 6.4.41+dfsg-0+deb13u1 | DEBIAN-CVE-2026-45133 |
| Debian:14 | symfony | 7.4.12+dfsg-1 | DEBIAN-CVE-2026-45133 |
| Packagist | symfony/symfony | 7.4.12 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/symfony | 8.0.12 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/symfony | 5.4.52 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/symfony | 6.4.40 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/yaml | 5.4.52 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/yaml | 6.4.40 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/yaml | 7.4.12 | GHSA-c2p3-7m5p-cv8x |
| Packagist | symfony/yaml | 8.0.12 | GHSA-c2p3-7m5p-cv8x |
| Ubuntu:25.10 | symfony | no fix listed | UBUNTU-CVE-2026-45133 |
| Ubuntu:26.04:LTS | symfony | no fix listed | UBUNTU-CVE-2026-45133 |
| Ubuntu:26.10 | symfony | no fix listed | UBUNTU-CVE-2026-45133 |
Affected products (as reported)
Weakness: CWE-674, CWE-776, CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/symfony/symfony/security/advisories/GHSA-c2p3-7m5p-cv8x x_refsource_CONFIRM
- https://github.com/symfony/symfony/releases/tag/v5.4.52 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v6.4.40 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v7.4.12 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v8.0.12 x_refsource_MISC