Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45063Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator

Critical 9.1

In plain English

A critical-severity authentication bypass by spoofing in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.1Critical
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, X509Authenticator extracts the user identifier from $_SERVER['SSL_CLIENT_S_DN'] with an unanchored regex that matches emailAddress= anywhere in the distinguished name, allowing an attacker with a trusted certificate containing emailAddress=victim inside another RDN value such as CN to authenticate as the victim. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.53+dfsg-0+deb12u1DEBIAN-CVE-2026-45063
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45063
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45063
Packagistsymfony/security-http5.4.52GHSA-ph86-p8f6-f9r2
Packagistsymfony/security-http6.4.40GHSA-ph86-p8f6-f9r2
Packagistsymfony/security-http7.4.12GHSA-ph86-p8f6-f9r2
Packagistsymfony/security-http8.0.12GHSA-ph86-p8f6-f9r2
Packagistsymfony/symfony8.0.12GHSA-ph86-p8f6-f9r2
Packagistsymfony/symfony5.4.52GHSA-ph86-p8f6-f9r2
Packagistsymfony/symfony6.4.40GHSA-ph86-p8f6-f9r2
Packagistsymfony/symfony7.4.12GHSA-ph86-p8f6-f9r2
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45063
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45063
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45063

Affected products (as reported)

VendorProductVersions
symfony symfony < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-290 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References