Actively exploited · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-42271LiteLLM: Authenticated command execution via MCP stdio test endpoints
High 8.8 Exploited
In plain English
A high-severity command injection in litellm from BerriAI. Attackers are actively exploiting it in the wild (listed by CISA on June 8, 2026). The chance it is exploited in the next 30 days is estimated at 91.4% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Jun 22, 2026.
Official description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | litellm | 1.83.7 | GHSA-v4p8-mg3p-g94g |
| PyPI | litellm | 1.83.7 | PYSEC-2026-2599 |
Affected products (as reported)
Weakness: CWE-77, CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g x_refsource_CONFIRM
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable x_refsource_MISC
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271 government-resource
- https://access.redhat.com/security/cve/CVE-2026-42271 vdb-entry, x_refsource_REDHAT
- RHBZ#2467924 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:28960 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:30056 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:27784 vendor-advisory, x_refsource_REDHAT