Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41137Flowise: Code Injection in CSVAgent leads to Authenticated RCE
Critical 9.4
In plain English
A critical-severity code injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, The CSVAgent allows providing a custom Pandas CSV read code. Due to lack of sanitization, an attacker can provide a command injection payload that will get interpolated and executed by the server. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-9wc7-mj3f-74xv |
| npm | flowise-components | 3.1.0 | GHSA-9wc7-mj3f-74xv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FlowiseAI | Flowise | < 3.1.0 |
| FlowiseAI | flowise-components | < 3.1.0 |
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9wc7-mj3f-74xv x_refsource_CONFIRM