Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M

CVE-2026-40347Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data

Medium 5.3

In plain English

A medium-severity uncontrolled resource consumption in python-multipart from Kludex. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 71.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-multipartno fix listedDEBIAN-CVE-2026-40347
Debian:13python-multipartno fix listedDEBIAN-CVE-2026-40347
Debian:14python-multipart0.0.26-1DEBIAN-CVE-2026-40347
PyPIpython-multipart0.0.26GHSA-mj87-hwqh-73pj
PyPIpython-multipart0.0.26PYSEC-2026-3038
Ubuntu:25.10python-multipartno fix listedUBUNTU-CVE-2026-40347
Ubuntu:26.04:LTSpython-multipartno fix listedUBUNTU-CVE-2026-40347
Ubuntu:26.10python-multipartno fix listedUBUNTU-CVE-2026-40347

Affected products (as reported)

VendorProductVersions
Kludex python-multipart < 0.0.26

Weakness: CWE-400, CWE-834 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References