Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M

CVE-2026-40176Composer is vulnerable to Command Injection via Malicious Perforce Repository

High 7.8

In plain English

A high-severity improper input validation in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)1.0%top 35.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23composer2.9.6-r0ALPINE-CVE-2026-40176
Alpine:v3.24composer2.9.6-r0ALPINE-CVE-2026-40176
Debian:12composer2.5.5-1+deb12u4DEBIAN-CVE-2026-40176
Debian:13composer2.8.8-1+deb13u2DEBIAN-CVE-2026-40176
Debian:14composer2.9.7-1DEBIAN-CVE-2026-40176
Packagistcomposer/composer2.2.27GHSA-wg36-wvj6-r67p
Packagistcomposer/composer2.9.6GHSA-wg36-wvj6-r67p
Ubuntu:25.10composerno fix listedUBUNTU-CVE-2026-40176
Ubuntu:26.04:LTScomposerno fix listedUBUNTU-CVE-2026-40176
Ubuntu:26.10composerno fix listedUBUNTU-CVE-2026-40176

Affected products (as reported)

VendorProductVersions
composer composer >= 2.3, < 2.9.6>= 1.0, < 2.2.27

Weakness: CWE-20, CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References