Vulnerability · Published Mar 4, 2026 · Assigned by openjs
CVE-2026-3520Multer vulnerable to Denial of Service via uncontrolled recursion
High 7.5
In plain English
A high-severity resource allocation without limits in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | multer | 2.1.1 | GHSA-5528-5vmv-3xc2 |
Affected products (as reported)
Weakness: CWE-674, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/expressjs/multer/security/advisories/GHSA-5528-5vmv-3xc2
- https://www.cve.org/CVERecord?id=CVE-2026-3520
- https://github.com/expressjs/multer/commit/7e66481f8b2e6c54b982b34c152479e096ce2752
- https://cna.openjsf.org/security-advisories.html
- https://access.redhat.com/security/cve/CVE-2026-3520 vdb-entry, x_refsource_REDHAT
- RHBZ#2444584 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3520.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:6174 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:6802 vendor-advisory, x_refsource_REDHAT