Vulnerability · Published Feb 27, 2026 · Assigned by openjs
CVE-2026-3304Multer vulnerable to Denial of Service via incomplete cleanup
High 7.5
In plain English
A high-severity security flaw in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | multer | 2.1.0 | GHSA-xf7r-hgr6-v32p |
Affected products (as reported)
Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/expressjs/multer/security/advisories/GHSA-xf7r-hgr6-v32p
- https://www.cve.org/CVERecord?id=CVE-2026-3304
- https://github.com/expressjs/multer/commit/739919097dde3921ec31b930e4b9025036fa74ee
- https://cna.openjsf.org/security-advisories.html
- https://access.redhat.com/security/cve/CVE-2026-3304 vdb-entry, x_refsource_REDHAT
- RHBZ#2443353 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3304.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:6174 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:6802 vendor-advisory, x_refsource_REDHAT