Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M
CVE-2026-32935phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack
High 8.2
In plain English
A high-severity security flaw in phpseclib from phpseclib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-phpseclib | 2.0.42-1+deb12u3 | DSA-6186-1 |
| Debian:12 | php-phpseclib | 2.0.42-1+deb12u3 | DEBIAN-CVE-2026-32935 |
| Debian:13 | php-phpseclib | 2.0.48-3+deb13u1 | DSA-6186-1 |
| Debian:13 | php-phpseclib | 2.0.48-3+deb13u1 | DEBIAN-CVE-2026-32935 |
| Debian:14 | php-phpseclib | 2.0.52-1 | DEBIAN-CVE-2026-32935 |
| Debian:12 | php-phpseclib3 | 3.0.19-1+deb12u4 | DEBIAN-CVE-2026-32935 |
| Debian:12 | php-phpseclib3 | 3.0.19-1+deb12u4 | DSA-6187-1 |
| Debian:13 | php-phpseclib3 | 3.0.43-2+deb13u1 | DEBIAN-CVE-2026-32935 |
| Debian:13 | php-phpseclib3 | 3.0.43-2+deb13u1 | DSA-6187-1 |
| Debian:14 | php-phpseclib3 | 3.0.50-1 | DEBIAN-CVE-2026-32935 |
| Debian:12 | phpseclib | 1.0.20-1+deb12u3 | DSA-6185-1 |
| Debian:12 | phpseclib | 1.0.20-1+deb12u3 | DEBIAN-CVE-2026-32935 |
| Debian:13 | phpseclib | 1.0.23-6+deb13u1 | DSA-6185-1 |
| Debian:13 | phpseclib | 1.0.23-6+deb13u1 | DEBIAN-CVE-2026-32935 |
| Packagist | phpseclib/phpseclib | 1.0.27 | GHSA-94g3-g5v7-q4jg |
| Packagist | phpseclib/phpseclib | 2.0.52 | GHSA-94g3-g5v7-q4jg |
| Packagist | phpseclib/phpseclib | 3.0.50 | GHSA-94g3-g5v7-q4jg |
| Ubuntu:25.10 | php-phpseclib | no fix listed | UBUNTU-CVE-2026-32935 |
| Ubuntu:24.04:LTS | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-32935 |
| Ubuntu:25.10 | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-32935 |
| Ubuntu:26.04:LTS | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-32935 |
| Ubuntu:26.10 | php-phpseclib3 | no fix listed | UBUNTU-CVE-2026-32935 |
| Ubuntu:22.04:LTS | phpseclib | 1.0.20-1+deb12u3build0.22.04.1 | UBUNTU-CVE-2026-32935 |
| Ubuntu:22.04:LTS | phpseclib | 1.0.20-1+deb12u3build0.22.04.1 | USN-8769-1 |
| Ubuntu:25.10 | phpseclib | no fix listed | UBUNTU-CVE-2026-32935 |
Affected products (as reported)
Weakness: CWE-208 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N