Vulnerability · Published Apr 9, 2026 · Assigned by apache
CVE-2026-29129Apache Tomcat: TLS cipher order is not preserved
High 7.5
In plain English
A high-severity broken cryptography in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | tomcat9 | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.117-2.el10_2.alma.1 | ALSA-2026:36790 |
| Debian:12 | tomcat10 | 10.1.55-1~deb12u1 | DEBIAN-CVE-2026-29129 |
| Debian:13 | tomcat10 | 10.1.55-1~deb13u1 | DEBIAN-CVE-2026-29129 |
| Debian:14 | tomcat10 | 10.1.54-1 | DEBIAN-CVE-2026-29129 |
| Debian:13 | tomcat11 | 11.0.22-1~deb13u1 | DEBIAN-CVE-2026-29129 |
| Debian:14 | tomcat11 | 11.0.21-1 | DEBIAN-CVE-2026-29129 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-29129 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-29129 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-29129 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.116 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.53 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.20 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat | 11.0.20 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat | 9.0.116 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat | 10.1.53 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat-coyote | 11.0.20 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat-coyote | 10.1.53 | GHSA-69cc-cv78-qc8g |
| Maven | org.apache.tomcat:tomcat-coyote | 9.0.116 | GHSA-69cc-cv78-qc8g |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2026-29129 |
| Ubuntu:26.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-29129 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.16 – through 11.0.1810.1.51 – through 10.1.529.0.114 – through 9.0.115 |
Weakness: CWE-327 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N