Vulnerability · Published Mar 4, 2026 · Assigned by GitHub_M
CVE-2026-28784Craft is affected by potential authenticated Remote Code Execution via Twig SSTI
High 8.6
In plain English
A high-severity security flaw in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Craft is a content management system (CMS). Prior to 5.8.22 and 4.16.18, it is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. For this to work, you must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against our recommendations for any non-dev environment. Alternatively, you can have a non-administrator account with allowAdminChanges disabled, but you have access to the System Messages utility. Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | craftcms/cms | 5.9.0-beta.1 | GHSA-qc86-q28f-ggww |
| Packagist | craftcms/cms | 4.17.0-beta.1 | GHSA-qc86-q28f-ggww |
Affected products (as reported)
Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/craftcms/cms/security/advisories/GHSA-qc86-q28f-ggww x_refsource_CONFIRM
- https://github.com/craftcms/cms/pull/18208 x_refsource_MISC
- https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production x_refsource_MISC