Vulnerability · Published Mar 16, 2026 · Assigned by GitHub_M

CVE-2026-28490Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle

High 8.3

In plain English

A high-severity broken cryptography in authlib from authlib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.1%top 96.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a cryptographic padding oracle vulnerability was identified in the Authlib Python library concerning the implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. Authlib registers RSA1_5 in its default algorithm registry without requiring explicit opt-in, and actively destroys the constant-time Bleichenbacher mitigation that the underlying cryptography library implements correctly. This issue has been patched in version 1.6.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-authlib1.2.0-1+deb12u2DEBIAN-CVE-2026-28490
Debian:13python-authlibno fix listedDEBIAN-CVE-2026-28490
Debian:14python-authlib1.6.9-1DEBIAN-CVE-2026-28490
PyPIauthlib1.6.9PYSEC-2026-2116
PyPIauthlib1.6.9GHSA-7432-952r-cw78
Ubuntu:25.10python-authlibno fix listedUBUNTU-CVE-2026-28490
Ubuntu:26.10python-authlibno fix listedUBUNTU-CVE-2026-28490

Affected products (as reported)

VendorProductVersions
authlib authlib < 1.6.9

Weakness: CWE-203, CWE-327 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References