Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M

CVE-2026-22771Envoy Extension Policy lua scripts injection causes arbitrary command execution

High 8.8

In plain English

A high-severity code injection in gateway from envoyproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.6%top 50.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/envoyproxy/gateway1.6.2GHSA-xrwg-mqj6-6m22
Gogithub.com/envoyproxy/gateway1.5.7GHSA-xrwg-mqj6-6m22
Gogithub.com/envoyproxy/gateway1.5.7, 1.6.2GO-2026-4312

Affected products (as reported)

VendorProductVersions
envoyproxy gateway < 1.5.7>= 1.6.0-rc.0, < 1.6.2

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References