Vulnerability · Published Feb 12, 2026 · Assigned by PostgreSQL

CVE-2026-2007PostgreSQL pg_trgm heap buffer overflow writes pattern onto server memory

High 8.2

In plain English

A high-severity heap buffer overflow in PostgreSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Heap buffer overflow in PostgreSQL pg_trgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the viability of attacks that lead to privilege escalation. PostgreSQL 18.1 and 18.0 are affected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10postgresql1818.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-contrib18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-docs18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-plperl18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-plpython318.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-private-devel18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-private-libs18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-server18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-server-devel18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-static18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-test18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-test-rpm-macros18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-upgrade18.3-1.el10_2ALSA-2026:19009
AlmaLinux:10postgresql18-upgrade-devel18.3-1.el10_2ALSA-2026:19009
Alpine:v3.20postgresql1515.16-r0, 15.17-r0ALPINE-CVE-2026-2007
Alpine:v3.21postgresql1515.17-r0ALPINE-CVE-2026-2007
Alpine:v3.22postgresql1515.16-r0, 15.17-r0ALPINE-CVE-2026-2007
Alpine:v3.20postgresql1616.12-r0, 16.13-r0ALPINE-CVE-2026-2007
Alpine:v3.21postgresql1616.12-r0, 16.13-r0ALPINE-CVE-2026-2007
Alpine:v3.22postgresql1616.12-r0, 16.13-r0ALPINE-CVE-2026-2007
Alpine:v3.23postgresql1616.12-r0, 16.13-r0ALPINE-CVE-2026-2007
Alpine:v3.24postgresql1616.12-r0, 16.13-r0ALPINE-CVE-2026-2007
Alpine:v3.21postgresql1717.8-r0, 17.9-r0ALPINE-CVE-2026-2007
Alpine:v3.22postgresql1717.8-r0, 17.9-r0ALPINE-CVE-2026-2007
Alpine:v3.23postgresql1717.8-r0, 17.9-r0ALPINE-CVE-2026-2007
Alpine:v3.24postgresql1717.8-r0, 17.9-r0ALPINE-CVE-2026-2007
Alpine:v3.23postgresql1818.2-r0ALPINE-CVE-2026-2007
Alpine:v3.24postgresql1818.2-r0ALPINE-CVE-2026-2007
Debian:14postgresql-1818.2-1DEBIAN-CVE-2026-2007
Rocky Linux:10postgresql180:18.3-1.el10RLSA-2026:19009

Affected products (as reported)

VendorProductVersions
n/a PostgreSQL 18 – before 18.2

Weakness: CWE-122, CWE-120 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

References