Vulnerability · Published Feb 5, 2026 · Assigned by GitHub_M

CVE-2025-68458webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior

Low 3.7

In plain English

A low-severity server-side request forgery in webpack from webpack. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.2%top 86.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Webpack is a module bundler. From version 5.49.0 to before 5.104.1, when experiments.buildHttp is enabled, webpack’s HTTP(S) resolver (HttpUriPlugin) can be bypassed to fetch resources from hosts outside allowedUris by using crafted URLs that include userinfo (username:password@host). If allowedUris enforcement relies on a raw string prefix check (e.g., uri.startsWith(allowed)), a URL that looks allow-listed can pass validation while the actual network request is sent to a different authority/host after URL parsing. This is a policy/allow-list bypass that enables build-time SSRF behavior (outbound requests from the build machine to internal-only endpoints, depending on network access) and untrusted content inclusion (the fetched response is treated as module source and bundled). This issue has been patched in version 5.104.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-webpackno fix listedDEBIAN-CVE-2025-68458
Debian:13node-webpackno fix listedDEBIAN-CVE-2025-68458
Debian:14node-webpack5.105.4+dfsg1+~cs15.13.23-2DEBIAN-CVE-2025-68458
Ubuntu:22.04:LTSnode-webpackno fix listedUBUNTU-CVE-2025-68458
Ubuntu:24.04:LTSnode-webpackno fix listedUBUNTU-CVE-2025-68458
Ubuntu:25.10node-webpackno fix listedUBUNTU-CVE-2025-68458
Ubuntu:26.04:LTSnode-webpackno fix listedUBUNTU-CVE-2025-68458
Ubuntu:26.10node-webpackno fix listedUBUNTU-CVE-2025-68458
npmwebpack5.104.1GHSA-8fgc-7cc6-rx7x

Affected products (as reported)

VendorProductVersions
webpack webpack >= 5.49.0, < 5.104.1

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N

References