Vulnerability · Published Aug 14, 2025 · Assigned by GitHub_M

CVE-2025-54867Youki Symlink Following Vulnerability

High 7.0

In plain English

A high-severity security flaw in youki from youki-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities).

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.2%top 90.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.

Affected products (as reported)

VendorProductVersions
youki-dev youki < 0.5.5

Weakness: CWE-61 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References