Vulnerability · Published Jul 11, 2025 · Assigned by apache
CVE-2025-48924Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
Medium 5.3
In plain English
A medium-severity security flaw in Apache Commons Lang from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 86% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | libcommons-lang-java | 2.6-10+deb12u1 | DEBIAN-CVE-2025-48924 |
| Debian:13 | libcommons-lang-java | 2.6-10+deb13u1 | DEBIAN-CVE-2025-48924 |
| Debian:14 | libcommons-lang-java | 2.6-11 | DEBIAN-CVE-2025-48924 |
| Debian:12 | libcommons-lang3-java | 3.12.0-2+deb12u1 | DEBIAN-CVE-2025-48924 |
| Debian:13 | libcommons-lang3-java | 3.17.0-1+deb13u1 | DEBIAN-CVE-2025-48924 |
| Debian:14 | libcommons-lang3-java | 3.17.0-2 | DEBIAN-CVE-2025-48924 |
| Maven | commons-lang:commons-lang | no fix listed | GHSA-j288-q9x7-2f5v |
| Maven | org.apache.commons:commons-lang3 | 3.18.0 | GHSA-j288-q9x7-2f5v |
| Ubuntu:22.04:LTS | libcommons-lang-java | 2.6-9ubuntu0.22.04.1 | UBUNTU-CVE-2025-48924 |
| Ubuntu:22.04:LTS | libcommons-lang-java | 2.6-9ubuntu0.22.04.1 | USN-8364-1 |
| Ubuntu:24.04:LTS | libcommons-lang-java | 2.6-10ubuntu0.1 | USN-8364-1 |
| Ubuntu:24.04:LTS | libcommons-lang-java | 2.6-10ubuntu0.1 | UBUNTU-CVE-2025-48924 |
| Ubuntu:22.04:LTS | libcommons-lang3-java | 3.11-1ubuntu0.1 | UBUNTU-CVE-2025-48924 |
| Ubuntu:22.04:LTS | libcommons-lang3-java | 3.11-1ubuntu0.1 | USN-8364-1 |
| Ubuntu:25.10 | libcommons-lang3-java | no fix listed | UBUNTU-CVE-2025-48924 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Commons Lang | 2.0 – through 2.6 |
| Apache Software Foundation | Apache Commons Lang | 3.0 – before 3.18.0 |
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1 vendor-advisory
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html
- http://www.openwall.com/lists/oss-security/2025/07/11/1
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html