Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M
CVE-2025-46557Any user with view access to the XWiki space can change the authenticator
High 8.4
In plain English
A high-severity missing authorization in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki is a generic wiki platform. In versions starting from 15.3-rc-1 to before 15.10.14, from 16.0.0-rc-1 to before 16.4.6, and from 16.5.0-rc-1 to before 16.10.0-rc-1, a user who can access pages located in the XWiki space (by default, anyone) can access the page XWiki.Authentication.Administration and (unless an authenticator is set in xwiki.cfg) switch to another installed authenticator. Note that, by default, there is only one authenticator available (Standard XWiki Authenticator). So, if no authenticator extension was installed, it's not really possible to do anything for an attacker. Also, in most cases, if an SSO authenticator is installed and utilized (like OIDC or LDAP for example), the worst an attacker can do is break authentication by switching back to the standard authenticator (that's because it's impossible to login to a user which does not have a stored password, and that's usually what SSO authenticator produce). This issue has been patched in versions 15.10.14, 16.4.6, and 16.10.0-rc-1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-security-authentication-ui | 15.10.14 | GHSA-f9c6-2f9p-82jj |
| Maven | org.xwiki.platform:xwiki-platform-security-authentication-ui | 16.4.6 | GHSA-f9c6-2f9p-82jj |
| Maven | org.xwiki.platform:xwiki-platform-security-authentication-ui | 16.10.0-rc-1 | GHSA-f9c6-2f9p-82jj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 15.3-rc-1, < 15.10.14>= 16.0.0-rc-1, < 16.4.6>= 16.5.0-rc-1, < 16.10.0-rc-1 |
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-f9c6-2f9p-82jj x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/5efc31cea1501c9a5cb593566fea8b558ff32a2a x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-22604 x_refsource_MISC