Actively exploited · Published Apr 16, 2025 · Assigned by GitHub_M
CVE-2025-32433Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
Critical 10.0 Exploited
In plain English
A critical-severity missing authentication in otp from erlang. Attackers are actively exploiting it in the wild (listed by CISA on June 9, 2025). The chance it is exploited in the next 30 days is estimated at 98.9% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Jun 30, 2025.
Official description
Erlang/OTP is a set of libraries for the Erlang programming language. Prior to versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20, a SSH server may allow an attacker to perform unauthenticated remote code execution (RCE). By exploiting a flaw in SSH protocol message handling, a malicious actor could gain unauthorized access to affected systems and execute arbitrary commands without valid credentials. This issue is patched in versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20. A temporary workaround involves disabling the SSH server or to prevent access via firewall rules.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | erlang | 26.2.5.11-r0 | ALPINE-CVE-2025-32433 |
| Debian:12 | erlang | 1:25.2.3+dfsg-1+deb12u1 | DSA-5906-1 |
| Debian:12 | erlang | 1:25.2.3+dfsg-1+deb12u1 | DEBIAN-CVE-2025-32433 |
| Debian:13 | erlang | 1:27.3.3+dfsg-1 | DEBIAN-CVE-2025-32433 |
| Debian:14 | erlang | 1:27.3.3+dfsg-1 | DEBIAN-CVE-2025-32433 |
| Ubuntu:22.04:LTS | erlang | 1:24.2.1+dfsg-1ubuntu0.4 | USN-7443-1 |
| Ubuntu:22.04:LTS | erlang | 1:24.2.1+dfsg-1ubuntu0.4 | UBUNTU-CVE-2025-32433 |
| Ubuntu:24.04:LTS | erlang | 1:25.3.2.8+dfsg-1ubuntu4.3 | UBUNTU-CVE-2025-32433 |
| Ubuntu:24.04:LTS | erlang | 1:25.3.2.8+dfsg-1ubuntu4.3 | USN-7443-1 |
Affected products (as reported)
Weakness: CWE-306 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2 x_refsource_CONFIRM
- https://github.com/erlang/otp/commit/0fcd9c56524b28615e8ece65fc0c3f66ef6e4c12 x_refsource_MISC
- https://github.com/erlang/otp/commit/6eef04130afc8b0ccb63c9a0d8650209cf54892f x_refsource_MISC
- https://github.com/erlang/otp/commit/b1924d37fd83c070055beb115d5d6a6a9490b891 x_refsource_MISC
- http://www.openwall.com/lists/oss-security/2025/04/16/2
- http://www.openwall.com/lists/oss-security/2025/04/18/1
- http://www.openwall.com/lists/oss-security/2025/04/18/2
- http://www.openwall.com/lists/oss-security/2025/04/18/6
- http://www.openwall.com/lists/oss-security/2025/04/19/1
- https://security.netapp.com/advisory/ntap-20250425-0001/
- https://lists.debian.org/debian-lts-announce/2025/04/msg00028.html
- https://github.com/ProDefense/CVE-2025-32433/blob/main/CVE-2025-32433.py exploit
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-erlang-otp-ssh-xyZZy vendor-advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32433 government-resource