Vulnerability · Published Mar 27, 2025 · Assigned by GitHub_M

CVE-2025-30355Synapse vulnerable to federation denial of service via malformed events

High 7.1

In plain English

A high-severity improper input validation in synapse from element-hq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)1.2%top 31.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.21synapse1.127.1-r0ALPINE-CVE-2025-30355
Alpine:v3.22synapse1.127.1-r0ALPINE-CVE-2025-30355
Alpine:v3.23synapse1.127.1-r0ALPINE-CVE-2025-30355
Alpine:v3.24synapse1.127.1-r0ALPINE-CVE-2025-30355
Debian:14matrix-synapse1.121.0-6DEBIAN-CVE-2025-30355
PyPImatrix-synapse1.127.1GHSA-v56r-hwv5-mxg6
PyPImatrix-synapse1.127.1PYSEC-2026-1614
Ubuntu:24.04:LTSmatrix-synapseno fix listedUBUNTU-CVE-2025-30355

Affected products (as reported)

VendorProductVersions
element-hq synapse < 1.127.1

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

References